Category Archives: wireless

Lucid Lynx

am a bit late, but have now installed Ubuntu 10.04 Lucid Lynx 64-bit (on a dell Studio 1747).

The installation went without a hitch, here are the major things I had to do afterwards. Actually, nothing major, mind you.

Wireless network: install required wired network, and then activating the Broadcom STA proprietary wireless driver ( > System > Administration > Hardware drivers)

Sound: No sound would play through the headphones. Solved by adding the following line to /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=dell-m6
See also: https://help.ubuntu.com/community/HdaIntelSoundHowto

…other issues and notes later.

Using NetworkManager for wireless networking

Finally, after much searching, trying and agonising wireless networking/internet connection is working!

Installed network-manager-gnome and wpasupplicant (or was that already installed?) through synaptic.

Created a /etc/wpa_supplicant.conf file as described here.
…but had no luck when it came to the step “Testing the configuration”. There seemed to be fewer error messages when using “wext” driver instead of “ipw” even though I have the Intel Pro/Wireless 2200BG. During testing I could tell that some things are working because different SSIDs from nearby networks were picked up, but authentication seemed to always fail (I checked and re-checked the SSID, passphrase (HEX), MAC address, etc.).

The whole time NetworkManager itself seemed to not be aware of my network adapter (i.e. clicking on the applet would only show “Wired Network”, nothing wireless).
Finally, I found this little gem of information:

“Debian and Ubuntu modified NetworkManager so that it would not manage any devices listed in /etc/network/interfaces. If you open this file and comment out the lines for the interfaces you want to manage and reboot NetworkManager will see them.”

…so, I commented out the two lines about eth1 and a reboot later NetworkManager worked just fine! Just had to select the network and enter the passphrase.

(the next day, I suddenly could no longer connect to my wireless network. After trying many things I went back to the aforementioned /etc/network/interfaces and sure enough a new line (I think it was “eth1 auto”) had appeared. After commenting that one out as well and rebooting, everything worked again.)

Note: eth1 is my wireless adapter and eth0 is the wired one.

Next: not having to enter the keyring at every log in.
I followed Part 1 of this explanation: http://www.ubuntuforums.org/showthread.php?t=316927
but only up to point 3. After that just a reboot, followed by one more input of the passphrase did the trick.

Now NetworkManager connects to the wireless network upon login without asking for any password again! 🙂

Note: some of these steps may be unnecessary for someone who uses no or only weak (WEP) encryption. The above setup is for a WPA encrypted wireless network.